Once again, there is a single installer for VS2015+2017, and now it sets correct TargetFSharpCoreVersion and web.config redirects correctly up for both. Thanks for the report.

By on 9/1/2017 6:41 AM ()

I have both visual studio 2015 and 2017 community, and when I tried to install the vsix, it only installed to 2015 (only a checkbox for 2015 was available; when I double clicked on the vsix again after 2015 install, I got a message saying the vsix has been installed to all applicable products). how can I get it to also install to 2017 ?

following adam granicz's suggestion, I was able to download a MyProject.zip client-server file, but I was wondering if I could get all project templates to install into 2017 in an easier way?



with the client-server MyProject.zip file downloaded from the developers web site (per adam's suggestion) , i'm getting the following error:

Error in InlineControl at C:\Jenkins\workspace\zafir.ui.next\WebSharper.UI.Next\Doc.fs: 418.58-418.79: Couldn't find translation of method MyProject.Client.Main. The method or type should have JavaScript attribute or a proxy, and the assembly needs to be compiled with WsFsc.exe

the same client-server project created with the vs2015 template worked just fine.


found the path to vs2017 vsixinstaller. all is fine now. sorry for the noise.

"C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VSIXInstaller.exe" WebSharper.

By on 10/3/2017 6:06 PM ()

Which is the current status of this topic? I'm interested because I have Visual Studio 2017 Community (on Windows 7) and I would like to try WebSharper? How should I proceed? Is there a good tutorial or some examples to start looking at? I'm coming from a WPF background, (I'm already using F# and functional programming there).

By on 1/3/2018 7:45 AM ()

The .vsix installer from the website should work just fine for you.

By on 1/3/2018 11:24 AM ()

I've tried with WebSharper. and Visual Studio 2017 Version 15.5.2 Community and I can't find the WebSharp templates. Honestly there is an issue also with the F# ones, even if I selected the F# support... In the meantime I'm starting to use WebSharper with VS2015 and of course I like its high level dsl representation for html/css!

By on 1/4/2018 7:23 AM ()

I just installed Visual Studio 2017 Community (15.5.2) and WebSharper, and things worked as expected.

By on 1/4/2018 3:19 PM ()

Thank you for your prompt support, your time and the helpful images you pasted. I must have done something wrong and I will repair my vs2017 installation this morning. Nice to see it works well with WebSharper. Again, I like very much the way WebSharper simplifies building web applications! It is really intuitive also for a developer like me, coming from the WPF and XAML world. Thank you and keep up with good work.

By on 1/5/2018 12:02 AM ()

You can also download the standard project templates directly from the developer site, by going to the Apps menu (right-most icon in the menu) and choosing Create a Project. Alternatively, you can do the same from the Terminal (a new feature we just added).

By on 8/31/2017 5:19 AM ()


sorry for the mix-up. For immediate fix, http://websharper.com/Zafir.vsix is the link for the VS2017 version and http://websharper.com/Zafir.VS2015.vsix is latest for VS2015.

We are coming up with a better way to expose and publish vsix right soon.

By on 8/31/2017 5:09 AM ()
IntelliFactory Offices Copyright (c) 2011-2012 IntelliFactory. All rights reserved.
Home | Products | Consulting | Trainings | Blogs | Jobs | Contact Us | Terms of Use | Privacy Policy | Cookie Policy
Built with WebSharper