This is described at You can comment on the ticket if you have any further problems, thanks!

By on 8/21/2017 8:45 AM ()

Yes, you're right, it is failing to download jQuery. You have two options to correct this:

  • If you're on WebSharper 4.0-beta7 or later, you can use the resource download feature:
    • Add <WebSharperDownloadResources>True</WebSharperDownloadResources> to your project file's <PropertyGroup> so that the compiler automatically downloads the files into /Scripts/WebSharper;
    • Add <add key="UseDownloadedResources" value="True" /> to your Web.config's <appSettings> so that WebSharper inserts a link to that downloaded file in your pages instead of a link to the online resource.

  • If you're on an older version of WebSharper, you can download the js file manually and add <add key="WebSharper.JQuery.Resources.JQuery" value="/path/to/jquery.js" /> to your Web.config's <appSettings> to override the link that WebSharper inserts in your pages.
By on 8/21/2017 8:44 AM ()

Hi That fixed it! Thanks. I don't think I have the beta version, so I only tried the second, manual method, and it worked great.


By on 8/24/2017 10:01 AM ()
IntelliFactory Offices Copyright (c) 2011-2012 IntelliFactory. All rights reserved.
Home | Products | Consulting | Trainings | Blogs | Jobs | Contact Us | Terms of Use | Privacy Policy | Cookie Policy
Built with WebSharper